Using Call Ctrl Outside SPA9000

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Using Call Ctrl Outside SPA9000


Overview

Call Ctrl is supported outside the SPA9000 enviornment with limited support available direct to the SPA IP Phone. Call Ctrl will support the SPA IP Phones in Hosted, Asterisk and other SIP-compliant IP PBX configurations.

The following definitions are required to describe the supported features:

  • Control : Allows Call Ctrl to perform actions against the phone, such as: New Call, End Call, Hold, Transfer, etc.
  • Status: This allows the phone to inform Call Ctrl of its status, such as: an Active or Ringing Call, Phone Details, Volume, etc.

When Call Ctrl is used outside the SPA9000, ONLY the CONTROL methods are available. Users have the same functionality when performing actions, but the phone will not receive the status of these actions when they are made. For example, users may make a call, but the Extension and Call instances will not reflect a call is being made in the Call Ctrl interface. This will simply require the users to use the phone display for status as opposed to Call Ctrl for determining what actions to perform and when. These limitations should not have a significant impact on the productivity Call Ctrl allows users, but simply a different approach to its utilization.

New Call Notification, Transfer and Conference are not available within Call Ctrl when the phones are not connected to the SPA9000.

 

Cause

Call Ctrl uses an API which is made available using the SPA9000 and the SPA IP Phone. The API is not fully implemented on the SPA IP Phone and requires the help of the SPA9000. Cisco has had plan for some time to make the API available regardless if used under the SPA9000.

Call Ctrl is currently under development to include complete support for Status and Control methods regardless of this feature being implemented in future firmware releases.

Resolution

To enable Call Ctrl to utilize the SPA IP Phone when the phone is NOT connected to the SPA9000 perform the following steps:

  1. Log into the SPA IP Phone web admin: http://spa-ip-phone-ip-address/
  2. Select Admin and then Advanced option to enabled the Advanced Admin options.
  3. Navigate to SIP Tab/Linksys Key System Parameters/Linksys Key System.
  4. Set Linksys Key System to Yes.
  5. The Phone should restart, if not restart it manually.
  6. Reconfigure Call Ctrl using the Settings Wizard and ensure the NO SPA9000 is selected during setup.


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Details
Last Modified:Thursday, August 05, 2010
Last Modified By: Administrator
Type: INFO
Rated 5 stars based on 1 vote
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